Intermittent failures on certificate requests and delays in certificates appearing in inventory

Incident Report for Venafi Control Plane

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 12:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 02:32 UTC

Monitoring

We’ve implemented a fix and are actively monitoring the situation. At this time, we do not anticipate any delays in certificate issuance. Other discovery operations may experience some delays, but performance is steadily improving.
Posted Jun 11, 2025 - 17:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2025 - 16:35 UTC

Update

We are continuing to investigate this issue.
Posted Jun 11, 2025 - 15:34 UTC

Investigating

We are currently investigating intermittent failures on certificate requests and delays in certificates appearing in inventory
Posted Jun 11, 2025 - 14:04 UTC
This incident affected: US (Certificate Issuance).