Intermittent failures on certificate requests and delays in certificates appearing in inventory

Incident Report for Venafi Control Plane

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 18:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 19, 2025 - 18:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 18:37 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 18:28 UTC

Investigating

We are currently investigating this issue.
Posted Mar 19, 2025 - 18:00 UTC
This incident affected: US (Certificate Issuance, Certificate Installation).